Debian 9.4 ошибка при установке

7 months 2 weeks ago #2093 by PolPav
PolPav created the topic: Debian 9.4 ошибка при установке
Здравствуйте. Пытаюсь установить SOPDS 0.45 На Debian 9.4. Версия django - 2.0.1. С установкой пакетов, вроде, разобрался, но видимо что-то упустил: при запуске инициализации базы "python3 manage.py migrate" получаю ошибку "django.db.utils.OperationalError: no such table: constance_config".
Warning: Spoiler! [ Click to expand ]
СУБД: mariaDB 10.1.26. Настройки:
Warning: Spoiler! [ Click to expand ]
Список установленных пакетов:
Warning: Spoiler! [ Click to expand ]
Проверка требований:
Warning: Spoiler! [ Click to expand ]
Пробовал инициализировать на sqlLite, но получил похожую ошибку. Подскажите куда копать, пожалуйста.

Please Войти or Create an account to join the conversation.

  • PolPav
  • PolPav's Avatar Topic Author
  • Offline
  • Новый участник
  • Новый участник
More
7 months 2 weeks ago #2094 by mitshel
mitshel replied the topic: Debian 9.4 ошибка при установке
Пока не могу сказать почему у Вас так получилось. Проверил последнюю версию на Github - проблем не нашел.
Попробуйте удалить базу данных sopds (DROP DATABASE sopds), а затем создать ее снова в соответствии с п 3. README. Ну и затем повторить миграцию.

Please Войти or Create an account to join the conversation.

  • mitshel
  • mitshel's Avatar
  • Offline
  • Администратор
  • Администратор
More
7 months 2 weeks ago #2095 by PolPav
PolPav replied the topic: Debian 9.4 ошибка при установке
Я уже пересоздавал базу ранее. Сейчас повторил процедуру снова. Даже установил пароль по-умолчанию. Это не помогло: ошибка та же.
Кроме того, меня смущает, что при использовании SQLLite возникает похожая ошибка:
Warning: Spoiler! [ Click to expand ]
Я подозреваю, что проблема в пакетах. Явно ошибка при работе с БД. Может дело в Django? Вот вывод диагностики: Django-admin --check
Warning: Spoiler! [ Click to expand ]
Все пакеты ставил из респозитория, так как Pip вывалился с ошибкой компиляции. Может в этом дело?

Please Войти or Create an account to join the conversation.

  • PolPav
  • PolPav's Avatar Topic Author
  • Offline
  • Новый участник
  • Новый участник
More
7 months 2 weeks ago #2096 by mitshel
mitshel replied the topic: Debian 9.4 ошибка при установке
покажите версии пакетов:
python -m pip freeze

Please Войти or Create an account to join the conversation.

  • mitshel
  • mitshel's Avatar
  • Offline
  • Администратор
  • Администратор
More
7 months 2 weeks ago #2097 by PolPav
PolPav replied the topic: Debian 9.4 ошибка при установке
Версии пакетов:
Warning: Spoiler! [ Click to expand ]

Please Войти or Create an account to join the conversation.

  • PolPav
  • PolPav's Avatar Topic Author
  • Offline
  • Новый участник
  • Новый участник
More
7 months 2 weeks ago #2098 by mitshel
mitshel replied the topic: Debian 9.4 ошибка при установке
Да, действительно, ошибка имеете место быть при версии django-constance==2.0.0. У меня стоит версия 2.1.0. - c ней все работает. В ближайшее время посмотрю в чем может быть дело. В результате либо исправлю версию в requirements.txt, либо устраню возникшую несовместимость...
Пока посоветую установить django-constance 2.1.0

Please Войти or Create an account to join the conversation.

  • mitshel
  • mitshel's Avatar
  • Offline
  • Администратор
  • Администратор
More
Time to create page: 0.483 seconds